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The first 20 things to do and notice with 

System Software 7.0

Based on 7.0 beta 4

1. Check out the new menu items.
• The Apple menu doesn’t look too different at first glance, but it definitely is! It’s user modifiable 

(w/o Font/DA mover!), and anything can be put into the Apple menu for quick and immediate 
access! The limit on items in the Apple menu is now 50 items. More info on putting things into the 
Apple Menu later.

• There is a new menu called “Label” which allows you to label icons whether or not you’re on a 
color or black and white system. Choose an icon and select a label from the Label menu. It’s 
another way to organize your system, and you would use this whenever you wanted to view by 
label, or find by label.

• The Special menu is called “SuperBeta” in this build, this will be “Special” in the final release.

• The ? menu is the Interactive or Balloon Help menu. Choose “Show Balloons” and move the 
cursor over any icon or menu item. This gives users instant help on items they see on the screen or 
in dialog boxes. Choose “Hide Balloons” to turn them off again.

• The “Applications” menu which takes the place of the “MultiFinder” icon is now a pull down 
menu which lists the open applications, and has menu items for hiding open applications and their 
windows. This doesn’t quit the application, it just hides the windows until you choose the grayed 
out application from the “Applications” menu. Holding down the Option key and clicking on the 
Desktop will hide the open application windows.

2. Check out the new System Folder organization.
• Open the System Folder, and notice the new folders called “Apple Menu Items”, “Extensions”, 

“Startup Items”, “Control Panels”, “Preferences” as well as a different look (and functionality) of 
the System file itself. You can drag System Folder items directly onto the System Folder icon, and 
the system will put them in the appropriate place (after it asks you if that’s OK of course!).

1. Apple Menu Items folder: Put icons (applications, documents, aliases, DAs or cdevs) in this 
folder so that they appear under the Apple menu. No need to restart, put them in, and choose 
them from the menu!

2. Extensions folder: This is the place where System Extensions (INITs) go. You’ll notice 
LaserWriter drivers, Chooser drivers, DAL drivers, etc. in this folder. INITs are loaded from the
Extension folder first, then the Control Panels folder, and then the System Folder.

3. Startup Items folder: Any application, document, cdev, or DA you want to start upon booting 
you machine goes in this folder. This folder is NOT for System Extensions (INITs)!
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4. Control Panels folder: Here’s where all your control panels live. There’s an alias to this folder 

in the Apple Menu for easy access. Remember, you can double click on a control panel 
anywhere, at anytime!

5. Preferences folder: This is where the files like “More preferences” and dictionaries go, but 
applications will need to be modified to put these files into the “right places”.

6. System file: You can double click on the System file to open it. Only fonts,  sounds and 
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keyboard resources go into the System File. No more Font/DA Mover, just drag new fonts or 

sounds to install.

3. Installing 6.x DAs, INITs and cdevs.
• Open the System File on an old 6.x system, or an old suitcase. Just drag a font, sound, DA or 

keyboard resource  onto the System Folder, and it will “do the right thing” and put it in its place 
(DAs & cdevs in the Apple Menu Items folder; fonts & sounds into the System file).

4. Almost Everything is double-clickable.
• Open the an old 6.x suitcase, or the old 6.x system file. Drag a DA onto the desktop (something 

like calculator) double click on it. In 7.0, DAs, fonts, sounds and cdevs can be opened by double 
clicking on them. It’s best to keep cdevs in the Control Panels folder however.

5. Viewing items.
• Choose “View by Name’ from the “View” menu. Notice the new outline view that you’ll get with 

every list view. Clicking on the little arrow next to a folder will show you what’s inside without 
opening a new window. That means you can see your entire hard disk in one window, and select 
items from different folders at the same time. Choosing multiple Finds to be viewed all at once will
automatically put you into this view

6. Finding things.
• Choose “Find” from the file menu to find a particular file. Choose “More Choices” if you want to 

find a file according to certain criteria (kind, label, modification date, etc.). Click on the check box 
“All at Once” if you want the items to be selected all at one time. You can then “do” something 
with the selected items like move them to a floppy, throw them away, or move them into a different
folder.

7. The Desktop.
• The Desktop is a new entity in 7.0. In Open File and Save File dialogs,  you’ll see a new button 

called “DeskTop” which replaces the “Drive” button. This button brings you to the desktop level 
where you can see and choose from all mounted volumes (instead of having to blindly cycle 
through as before). There is another new button in the Save dialog box called “New Folder” which 
allows you to create a new folder when saving a document.

8. Navigation
• You can navigate with the keyboard now in 7.0. In an open window choose the first letter of an 

icon you’re looking for, or use the arrow keys to navigate right, left, up and down. The Tab key 
moves alphabetically, Shift-Tab is reverse alphabetical.

• When a window’s open, hold down the Command key and click on the name of the open window. 
You’ll see the path to the open window. You can navigate by releasing the mouse on any window in
the hierarchy. 
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• All of the command keys that work in the Open dialog will work in the Finder.

9. The Chooser
• There’s a new Chooser in 7.0. The new Chooser has a bigger window with almost-unlimited zones 

(~16,000 nodes per zone limitation) and shows up to 32 characters names in an alphabetized list 
(device and zone).  Keyboard input is accepted as well for easier access. The user’s name is now 
found in the ‘Control Panels’ folder in the cdev called ‘Sharing 
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Setup’.

10. Virtual Memory
• There’s a new panel in the Control Panels folder called “Memory” which allows a user to go 

beyond the physical limitations of RAM. This is for the user who wants to start up that one more 
application, not someone using a memory intensive application which requires double the existing 
amount of RAM. To start up VM, double click on the Memory cdev, and click on the radio button 
which turns VM on. It will allow you to choose any mounted hard disk (not network devices). The 
default setting is double your physical RAM (if you’ve got 2 Mb RAM, suggested maximum for 
VM is 4Mb TOTAL memory). If you have a IIci, IIsi, IIfx or LC you will also be able to click on 
the “32-bit addressing” radio button. This would allow you to extend VM up to 1 Gigabyte (LC 
cannot run VM because it doesn’t have a PMMU).

11. Background Copying
• If you have an application open, and want to copy something from a fileserver, but still want to 

work on your document while you’re doing it--you can! Remember, you must have the application 
open, and the window visible in order to go back to it.

12. Refinements 
• The first thing you notice when you start 7.0 on a color or gray scale system is that the windows 

have a very subtle shading to them. This is a user definable item you find in the “Color” cdev. 
Open the Control Panels, and the “Color” cdev. Change the color.

• Zooming: Doesn’t obliterate your screen to click on the zoom box anymore. The window will open
to as large as it needs to. Try it.

• Band selection: Band select several items in a window. If there are items not visible, hold the 
cursor at the edge of the window, and it will automatically scroll for you.

• Moving icons: Move an icon from a visible portion of a window to the portion that’s not visible 
(where the scroll bars are--to the right or below. Hold the icon at the edge to have the window 
scroll). The window will automatically scroll for you. If you want to move an icon from an inactive
window to an active window, the inactive window won’t become active until you let go of the 
mouse. It makes it much easier to move items between windows!

• Emptying the trash: The trash will not longer empty whenever it feels like it. It will empty only 
when the users chooses “Empty Trash” from the Special Menu.

• Renaming files: a user must explicitly click on the name of an icon to change it. A box will 
surround the name, and then the name is editable. When file sharing is turned on, the user cannot 
rename the hard disk.

• The 7.0 LaserWriter drivers save the state you left the setup in. If you chose black and white, it will
remain that way until you change it to color/gray scale.

13. TrueType 
• There are four TrueType fonts available in your 7.0 system: Times, Helvetica, Courier and Symbol.

These fonts will allow you to create presentations in any size, and you don’t need the bitmap 
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version for that exact size in your system! The extended set will be available at a later date, and 
more will certainly come from font developers. 

14. Aliases 
• Under the File menu you’ll find a new menu item called “Make Alias” which allows you to create 

links to any icon. The flashiest demo is to create an alias to a fileserver, put it in your Apple menu, 
unmount the original fileserver, and choose the alias from the Apple menu. You can also put the 
alias on a floppy, go to a different machine and double click on it. Aliases allow users to have 
multiple links to icons, and makes access much easier. 
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15. Stationery 
• For those applications which don’t already support stationery, it’s now built in. You can create a 

template of a document, and never make the mistake of overwriting it again. A good example is an 
expense report. Open a generic expense report, and fill in all the static info (like your name, 
employee number, etc.) save the file, and do a get info on it. Check the Stationery box, and then 
double click on the file again. You will be asked immediately to name the new file. This means that
you’ll never overwrite the original again!

16. File Sharing 
• Open the Control Panels from the Apple Menu. Double click on the “Sharing Setup” cdev. Fill in 

the appropriate information, and click “Start” for starting up File Sharing. Now close the cdev. 
Open the cdev called “Users & Groups” and choose “New User” from the File menu. Give the new
user a password, name, etc., and close the cdev. Choose a folder you want to make available to that
user, select it, and choose “Sharing” from the file menu. Click the box that says “Enable Sharing”, 
and choose the name of the user you just created. Then go to a 6.x system, go into the Chooser, 
select that machine name, log on, and now you have access to the folder that was shared!

17. Fileserver access and Privileges 
• Connect to a fileserver you have write access to. Create a folder on the fileserver, and choose 

“Sharing” from the File menu to set the privileges. The Get Privileges menu has been replaced with
the Sharing menu.

18. General Compatibility 
• One of the greatest things about 7.0 is that you can run most of the applications you ran on a 6.x 

system!  The Compatibility Checker on the Before You Install 7.0 disk will be available when 7.0 
ships, and it will list those applications know to be incompatible with 7.0. Those things that might 
not work well are cdevs like spell checkers, or INITs. 

19. Screen Snapshot built into the system. 
• Command-Shift-3 will now take a screen shot of your screen, and create a color PICT document. It

also makes a noise like a camera shutter, but don’t worry, your system didn’t crash.

20. Edition Manager 
• If you have the 7.0 developer CD, you will find some demo applications for demoing publish and 

subscribe called dpWrite and dpDraw. Open these applications simultaneously, and create a draw 
document. Publish it from the Edit menu. Choose dpWrite from the Applications menu and choose 
“Subscribe to...” from the Edit menu. Choose the edition you just created, and see it appear. These 
applications are demo software, not a 3rd party application. 
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